#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a class="biz-name[\w\W]*?<span>(.*?)<\/span>"
Local $sString = "<a class="biz-name"><span>Gus’s World Famous Fried Chicken</span></a>" & @CRLF & _
"<a class="biz-name"><span>South City Kitchen - Midtown</span></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")