re = /<a class="biz-name[\w\W]*?<span>(.*?)<\/span>/
str = '<a class="biz-name"><span>Gus’s World Famous Fried Chicken</span></a>
<a class="biz-name"><span>South City Kitchen - Midtown</span></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end