// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a class="biz-name[\w\W]*?<span>(.*?)<\/span>"#).unwrap();
let string = "<a class=\"biz-name\"><span>Gus’s World Famous Fried Chicken</span></a>
<a class=\"biz-name\"><span>South City Kitchen - Midtown</span></a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}