using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a class=""biz-name[\w\W]*?<span>(.*?)<\/span>";
string input = @"<a class=""biz-name""><span>Gus’s World Famous Fried Chicken</span></a>
<a class=""biz-name""><span>South City Kitchen - Midtown</span></a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}