package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a class="biz-name[\w\W]*?<span>(.*?)<\/span>`)
var str = `<a class="biz-name"><span>Gus’s World Famous Fried Chicken</span></a>
<a class="biz-name"><span>South City Kitchen - Midtown</span></a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}