import re
regex = re.compile(r"<a class=\"biz-name[\w\W]*?<span>(.*?)<\/span>")
test_str = ("<a class=\"biz-name\"><span>Gus’s World Famous Fried Chicken</span></a>\n"
"<a class=\"biz-name\"><span>South City Kitchen - Midtown</span></a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")