import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a class=\"biz-name[\\w\\W]*?<span>(.*?)<\\/span>";
final String string = "<a class=\"biz-name\"><span>Gus’s World Famous Fried Chicken</span></a>\n"
+ "<a class=\"biz-name\"><span>South City Kitchen - Midtown</span></a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}