#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)SI-?(\d{2,5})[\s|-]*(III|IV|V|6|6s)[\s|-]+(\w{4,6})[\s|-]+[ø|Ø|d]?\s?(\d{2})"
Local $sString = "SI-130-6 F75D Ø40"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")