$re = '/SI-?(\d{2,5})[\s|-]*(III|IV|V|6|6s)[\s|-]+(\w{4,6})[\s|-]+[ø|Ø|d]?\s?(\d{2})/i';
$str = 'SI-130-6 F75D Ø40';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);