const regex = /SI-?(\d{2,5})[\s|-]*(III|IV|V|6|6s)[\s|-]+(\w{4,6})[\s|-]+[ø|Ø|d]?\s?(\d{2})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SI-?(\\d{2,5})[\\s|-]*(III|IV|V|6|6s)[\\s|-]+(\\w{4,6})[\\s|-]+[ø|Ø|d]?\\s?(\\d{2})', 'i')
const str = `SI-130-6 F75D Ø40`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}