import Foundation
let pattern = #"SI-?(\d{2,5})[\s|-]*(III|IV|V|6|6s)[\s|-]+(\w{4,6})[\s|-]+[ø|Ø|d]?\s?(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"SI-130-6 F75D Ø40"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}