using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SI-?(\d{2,5})[\s|-]*(III|IV|V|6|6s)[\s|-]+(\w{4,6})[\s|-]+[ø|Ø|d]?\s?(\d{2})";
string input = @"SI-130-6 F75D Ø40";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}