package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)SI-?(\d{2,5})[\s|-]*(III|IV|V|6|6s)[\s|-]+(\w{4,6})[\s|-]+[ø|Ø|d]?\s?(\d{2})`)
var str = `SI-130-6 F75D Ø40`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}