#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<data_[a-zA-z]{3} .*?>"
Local $sString = "<data_let пробел**какие угодно символы кроме >" & @CRLF & _
"" & @CRLF & _
"<data_abc asasgfgag12414.*asfasf>" & @CRLF & _
"" & @CRLF & _
"<data_ABC asgasg>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")