import re
regex = re.compile(r"<data_[a-zA-z]{3} .*?>")
test_str = ("<data_let пробел**какие угодно символы кроме >\n\n"
"<data_abc asasgfgag12414.*asfasf>\n\n"
"<data_ABC asgasg>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")