import Foundation
let pattern = #"<data_[a-zA-z]{3} .*?>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<data_let пробел**какие угодно символы кроме >
<data_abc asasgfgag12414.*asfasf>
<data_ABC asgasg>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)