$re = '/<data_[a-zA-z]{3} .*?>/';
$str = '<data_let пробел**какие угодно символы кроме >
<data_abc asasgfgag12414.*asfasf>
<data_ABC asgasg>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);