import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<data_[a-zA-z]{3} .*?>";
final String string = "<data_let пробел**какие угодно символы кроме >\n\n"
+ "<data_abc asasgfgag12414.*asfasf>\n\n"
+ "<data_ABC asgasg>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}