using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<data_[a-zA-z]{3} .*?>";
string input = @"<data_let пробел**какие угодно символы кроме >
<data_abc asasgfgag12414.*asfasf>
<data_ABC asgasg>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}