import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$";
final String string = " cat \n\n\n"
+ "|-- Usage Example --|\n\n"
+ "Javascript:\n"
+ "\" Your string \".replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , '' );\n\n"
+ "function trim( str ){\n"
+ " return str.replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , '' );\n"
+ "}\n\n"
+ "PHP:\n"
+ "preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/' , '' , \" Your string \" );\n\n"
+ "function trim( $str=\"\" ){\n"
+ " return preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/' , '' , $str );\n"
+ "}\n\n"
+ "Output: \"Your string\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}