const regex = /^[ \s\0\x0B]+|[ \s\0\x0B]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$', 'gm')
const str = ` cat
|-- Usage Example --|
Javascript:
" Your string ".replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+\$/g , '' );
function trim( str ){
return str.replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+\$/g , '' );
}
PHP:
preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+\$/' , '' , " Your string " );
function trim( \$str="" ){
return preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+\$/' , '' , \$str );
}
Output: "Your string"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}