// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ \s\0\x0B]+|[ \s\0\x0B]+$").unwrap();
let string = " cat
|-- Usage Example --|
Javascript:
\" Your string \".replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , '' );
function trim( str ){
return str.replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , '' );
}
PHP:
preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/' , '' , \" Your string \" );
function trim( $str=\"\" ){
return preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/' , '' , $str );
}
Output: \"Your string\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}