import Foundation
let pattern = #"^[ \s\0\x0B]+|[ \s\0\x0B]+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
cat
|-- Usage Example --|
Javascript:
" Your string ".replace( /^[ \s\0\x0B]+|[ \s\0\x0B]+$/g , '' );
function trim( str ){
return str.replace( /^[ \s\0\x0B]+|[ \s\0\x0B]+$/g , '' );
}
PHP:
preg_replace( '^[ \s\0\x0B]+|[ \s\0\x0B]+$/' , '' , " Your string " );
function trim( $str="" ){
return preg_replace( '^[ \s\0\x0B]+|[ \s\0\x0B]+$/' , '' , $str );
}
Output: "Your string"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)