use strict;
my $str = ' cat
|-- Usage Example --|
Javascript:
" Your string ".replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , \'\' );
function trim( str ){
return str.replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , \'\' );
}
PHP:
preg_replace( \'^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/\' , \'\' , " Your string " );
function trim( $str="" ){
return preg_replace( \'^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/\' , \'\' , $str );
}
Output: "Your string"';
my $regex = qr/^[ \s\0\x0B]+|[ \s\0\x0B]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}