import re
regex = re.compile(r"^[ \s\0\x0B]+|[ \s\0\x0B]+$", flags=re.MULTILINE)
test_str = (" cat \n\n\n"
"|-- Usage Example --|\n\n"
"Javascript:\n"
"\" Your string \".replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , '' );\n\n"
"function trim( str ){\n"
" return str.replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , '' );\n"
"}\n\n"
"PHP:\n"
"preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/' , '' , \" Your string \" );\n\n"
"function trim( $str=\"\" ){\n"
" return preg_replace( '^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/' , '' , $str );\n"
"}\n\n"
"Output: \"Your string\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")