#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^event\s*\[(\d+),"([^"]+)",(\{.*\})\]$"
Local $sString = "Handshake [0,"957529506107a4c7b3dba869424463",1,"Ratchet/0.3.6"]" & @CRLF & _
"Event [8,"316662",{"id":1115411,"side":"left"}]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")