import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^event\\s*\\[(\\d+),\"([^\"]+)\",(\\{.*\\})\\]$";
final String string = "Handshake [0,\"957529506107a4c7b3dba869424463\",1,\"Ratchet/0.3.6\"]\n"
+ "Event [8,\"316662\",{\"id\":1115411,\"side\":\"left\"}]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}