package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^event\s*\[(\d+),"([^"]+)",(\{.*\})\]$`)
var str = `Handshake [0,"957529506107a4c7b3dba869424463",1,"Ratchet/0.3.6"]
Event [8,"316662",{"id":1115411,"side":"left"}]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}