using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^event\s*\[(\d+),""([^""]+)"",(\{.*\})\]$";
string input = @"Handshake [0,""957529506107a4c7b3dba869424463"",1,""Ratchet/0.3.6""]
Event [8,""316662"",{""id"":1115411,""side"":""left""}]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}