const regex = /^event\s*\[(\d+),"([^"]+)",(\{.*\})\]$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^event\\s*\\[(\\d+),"([^"]+)",(\\{.*\\})\\]$', 'gmi')
const str = `Handshake [0,"957529506107a4c7b3dba869424463",1,"Ratchet/0.3.6"]
Event [8,"316662",{"id":1115411,"side":"left"}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}