// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)^event\s*\[(\d+),"([^"]+)",(\{.*\})\]$"#).unwrap();
let string = "Handshake [0,\"957529506107a4c7b3dba869424463\",1,\"Ratchet/0.3.6\"]
Event [8,\"316662\",{\"id\":1115411,\"side\":\"left\"}]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}