re = /^event\s*\[(\d+),"([^"]+)",(\{.*\})\]$/mi
str = 'Handshake [0,"957529506107a4c7b3dba869424463",1,"Ratchet/0.3.6"]
Event [8,"316662",{"id":1115411,"side":"left"}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end