# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(.*?)\]\((.*?)\)/<a href="$2">$1<\/a>/g;t' <<< "Welcome to my [homepage](http://example.com) ,Please check our [About us](http://example.com/about-us) page for more info about this site."