using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(.*?)\]\((.*?)\)";
string substitution = @"<a href=""$2"">$1</a>";
string input = @"Welcome to my [homepage](http://example.com) ,Please check our [About us](http://example.com/about-us) page for more info about this site.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}