use strict;
my $str = 'Welcome to my [homepage](http://example.com) ,Please check our [About us](http://example.com/about-us) page for more info about this site.';
my $regex = qr/\[(.*?)\]\((.*?)\)/p;
my $subst = '<a href="$2">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";