import Foundation
let pattern = #"\[(.*?)\]\((.*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Welcome to my [homepage](http://example.com) ,Please check our [About us](http://example.com/about-us) page for more info about this site."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$2">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)