$re = '/\[(.*?)\]\((.*?)\)/';
$str = 'Welcome to my [homepage](http://example.com) ,Please check our [About us](http://example.com/about-us) page for more info about this site.';
$subst = "<a href=\"$2\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;