// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[(.*?)\]\((.*?)\)").unwrap();
let string = "Welcome to my [homepage](http://example.com) ,Please check our [About us](http://example.com/about-us) page for more info about this site.";
let substitution = "<a href=\"$2\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}