#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[(.*?)\]\((.*?)\)"
Local $sString = "Welcome to my [homepage](http://example.com) ,Please check our [About us](http://example.com/about-us) page for more info about this site."
Local $sSubst = "<a href="$2">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)