#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$"
Local $sString = "0712912826" & @CRLF & _
"0700000000" & @CRLF & _
"0710000000" & @CRLF & _
"0721234567" & @CRLF & _
"0731234567" & @CRLF & _
"0791234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")