using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$";
string input = @"0712912826
0700000000
0710000000
0721234567
0731234567
0791234567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}