re = /^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$/m
str = '0712912826
0700000000
0710000000
0721234567
0731234567
0791234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end