const regex = /^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$', 'gm')
const str = `0712912826
0700000000
0710000000
0721234567
0731234567
0791234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}