import re
regex = re.compile(r"^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$", flags=re.MULTILINE)
test_str = ("0712912826\n"
"0700000000\n"
"0710000000\n"
"0721234567\n"
"0731234567\n"
"0791234567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")