package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$`)
var str = `0712912826
0700000000
0710000000
0721234567
0731234567
0791234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}