import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s) +|^ +(?=\\s)| (?= +[\\n\\0])";
final String string = " .LW 30\n"
+ "Properly formatting a file where\n"
+ "there \n"
+ "is\n\n"
+ " a smattering of white space throughout\n"
+ " really means eliminating that \n"
+ "extra\n"
+ " white \n"
+ " space \n"
+ "such that the result\n"
+ " looks neat \n"
+ " and\n"
+ " very\n"
+ " tidy. \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}