$re = '/(?<=\s) +|^ +(?=\s)| (?= +[\n\0])/';
$str = ' .LW 30
Properly formatting a file where
there
is
a smattering of white space throughout
really means eliminating that
extra
white
space
such that the result
looks neat
and
very
tidy.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);