const regex = new RegExp('(?<=\\s) +|^ +(?=\\s)| (?= +[\\n\\0])', 'g')
const str = ` .LW 30
Properly formatting a file where
there
is
a smattering of white space throughout
really means eliminating that
extra
white
space
such that the result
looks neat
and
very
tidy.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}