import re
regex = re.compile(r"(?<=\s) +|^ +(?=\s)| (?= +[\n\0])")
test_str = (" .LW 30\n"
"Properly formatting a file where\n"
"there \n"
"is\n\n"
" a smattering of white space throughout\n"
" really means eliminating that \n"
"extra\n"
" white \n"
" space \n"
"such that the result\n"
" looks neat \n"
" and\n"
" very\n"
" tidy. \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")