# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d(m)"/000/gm;t' <<< "{
\"test1\": [\"300m\",\"50m\",\"0\",\"4\",\"1050m\"],
\"test2\": [\"600m\",\"400m\",\"10m\",\"0\",\"2\"],
...
}"